Jump to content
Sign in to follow this  
Claudio

Nav VI Not Detected by R1250RT Bike/Mount

Recommended Posts

Claudio

Symptoms

- The Nav VI does not wake up/power up when the bike is turned on.

- When I turn it on manually, dock it on the bike, then turn on the bike, the bike does not detect it (no "Nav" option in the menu). It doesn't show that its charging when the bike is on.  When I remove it from the dock after this, the unit detects that it has been "disconnected" and prompts whether I want to turn it off or allow it to sleep. (this means its aware of the mount).

 

I've troubleshot a few obvious things.

1) Ensure Nav VI is fully charged and running latest updates.

2) Ensure Nav VI is properly seated on the mount.

 

Taking it to the dealership later this week but thought I would check if anyone here has experienced and solved the issue.

 

 

Share this post


Link to post
Carlisja

If it used to work,  pull the Tupperware around the mount and make sure the pluc is eaten firmly.    If it is new to the bike, the dealership will need to update the bikes computer.

Share this post


Link to post
Inigo

I had the same problem several years ago with my NAV V.  I tried cleaning the contacts on the mount and on the back of the GPS.  No issues since.

Share this post


Link to post
gordiet

I clean the contacts with alcohol every few months. Us to have issues but no more.

Share this post


Link to post
Claudio

I cracked it open,  harness had never been plugged in from factory despite that option being ticked on the spec sheet.  Plugged it in to the bike harness and all is well.

  • Thanks 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...