Jump to content

GS-911 wifi

C Wallace

Recommended Posts

Couldn't get mine to work today, when I plugged it into my laptop the interface just flashed "connected, initialising". Anybody else having a problem with theirs?

Link to comment

I actually used mine about an hour ago to help a friend who's engine light came on. It seemed a little slow but eventually connected. I attributed the slowness to the fact that it was the first time I had connected it to his bike. All ended well though. The fan plug came lose and kicked a code when the temp reached the point where the fan is supposed to kick on. Pushed the plug in, reset the code, idled the bike until the fan kicked on and he is on his way.


Other than the slowness, it worked fine.


Link to comment

Used it a year ago to reset the service indicator at 6k miles, worked fine then. I think the unit is ok as it will talk to my iPhone. Think the problem is with getting the new beta into my laptop.

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...