Jump to content

04 RT Speedo/Odo stopped working...


Recommended Posts

I had the "new" 04 RT out for a test ride last weekend and

about 20 miles into the ride, the Speedometer and Odometers

stopped working. The bike works fine in every other way.


I did have the front wheel off the bike as I was working on

it over the winter but nothing different than what I would

normally do on services and tire changes.


Without my jumping to any conclusions, does anyone have any

thoughts on what I should look for to correct the problem?


That being said... as I bought the bike from a guy who

lived on the Outer Banks and didn't take it out of the shed

very often, I've been dealing with replacing some rusted

parts here and there. One thing I haven't touched yet is

the part in this picture here. Could this be the cause?





It looks to me that it could be Part Number 7 that has all

the rust on it. Is this the root cause? It's only a $2

part but what's involved in replacement?


Any other Thoughts or ideas on the problem????



Link to comment

Wow......yuck. Yes, that definitely could have something to do with it. Those little rusty tabs make contact with a set of nylon tabs in the speedo drive unit. The front wheel turns the metal tabs, which turn the nylon tabs, which spin a worm gear, which spins the speedo cable, which makes your speedo and odometer go roundy round.


First, I would disconnect the speedo cable from the hub and spin the front wheel. Look down where the cable attaches and see if the little fork piece in there is spinning. Even if it is spinning, you might want to use your finger to introduce some resistance to it. You will most likely find out that it will not spin freely.


On my bike, I've had the worm gear strip out once, and the nylon tabs strip out once. The worm gear means buying a new speedo drive unit. If it is just the nylon tabs though.......you can usually get by with grabbing those metal tabs with a pair of pliers and pulling/bending them a little closer towards the speedo drive unit. That should get them back in contact with the nylon tabs again.


Also, take a good look at the nylon tabs on the speedo drive unit. You might have to trim a new flat contact surface on the tab with an exacto knife. Considering how long speedometers have been used on moving vehicles......its an incredibly piss poor design.

Link to comment

Thanks for the confirmation...


Is this one of those slave cylinder things where I can

cause more harm by riding it... Or can I ride until I get

around to replacing it? The Speedo Unit (Part Number 14)

is $48 and would hate to cause it harm.


Any ideas on what the procedure is to replace that Driving

Dog part number 7?



Link to comment

First - I guess you already pulled the speedometer cable out of the sheath to confirm that it isn't broken.

That said - to get part 7 out, you just remove the grease seal (pry it out with a pair of screw drivers or something), then lift part 7 (the speedometer drive dog) out. Actually, I can't remember if there is a circlip holding it in, but you will know when you remove the grease seal. There are two metal tabs that sit in two matching notches in the wheel. On my bike, the metal tabs had been chewed off, and so I just replaced the drive dog for a couple of bucks. Push the grease seal back in, and you are done. Also, as noted earlier, check the nylon drive wheel that the drive dog pushes against. The metal can lose contact with the nylon, but when that happens, the speedometer usually goes wacky, and doesn't stop working.

Link to comment
I had the "new" 04 RT out for a test ride last weekend and

about 20 miles into the ride, the Speedometer and Odometers

stopped working. Any other Thoughts or ideas on the problem????



Have you checked the most likely culpit - a broken cable?


Link to comment
I had the "new" 04 RT out for a test ride last weekend and

about 20 miles into the ride, the Speedometer and Odometers

stopped working. Any other Thoughts or ideas on the problem????



Have you checked the most likely culpit - a broken cable?



Hi Everyone,


OK I've got everything disassembled and checked the speedo

unit. It appears OK and the worm gear or nylon gear isn't

stripped out.


However, on the two nylon tabs, it appears that there are

two different "levels" of the top surface on each tab

almost as if the metal tabs ground down into the inner half

of the nylon top. I have bent the tabs up as suggested and

believe that may solve the problem. Won't know until I get

back home this weekend for a test ride.


Just curious though, how does one know if the cable is

broken? I'm not exactly sure how/where to pull back on the

sheathing like with a throttle cable, nor what to look

for. Probably be a good thing to know even if this isn't

the root cause.


I did also try to pry out the seal but it doesn't seem to

want to budge and I didn't want to cause any damage... Any

tricks of the trade here???


Thanks again for the ideas... It always interesting to see

how everything works!



Link to comment

We just fixed the exact same problem on James's bike, no speedo indication and stripped nylon tabs in the speedo drive housing. We thought that the speedo drive had frozen up so we ordered a new one and installed it, but still no speed indication. We then pulled the speedo cable itself and found that it was pretty gummed up, requiring a very high torque to turn it (more apparently than the speedo drive could provide.) We cleaned off the speedo cable with WD40 and reinstalled it and it then turned easily and the speedometer worked properly. IOW, the sticky cable caused the first drive unit to fail at the weakest point (the nylon drive tabs.) Yours sounds like a similar situation.


You should be able to turn the drive cable very easily with a screwdriver and it should be easy to slide the cable out of the sheath. If it is hard to turn that is likely your problem, remove the cable from the sheath and clean it. At this point it sounds like you will probably have to replace the drive unit as well.

Link to comment

I tried the screwdriver trick on the speedo cable and it is

turning very easily.


Now I'm really interested to see if it's working, I'm going

to put it all back together now and take it out for a test

run. Back in a little bit!

Link to comment

All Set!!! smile.gif


It looks like bending the metal tabs up solved the problem. Works perfectly now.


Thanks again for all the help! thumbsup.gif

Link to comment

Another good trick is putting the cable in a cordless drill to see if the speedo works. I think it needs to be in reverse. Glad you fixed the problem.....

Link to comment


This topic is now archived and is closed to further replies.

  • Create New...