Jump to content
IGNORED

RID DOA


TedKerr

Recommended Posts

Howdy folks, hoping to get some advise on how to fix a seemingly dead RID on my 2004 R1150RT. With the key on the RID backlight comes on but all of the expected information – engine temp, fuel level and clock – is gone. The clock is supposed to display with key on or off but it’s gone either way. The bike runs fine otherwise. 

 

After some searching for ideas I’ve tried wiggling the RID wiring, jiggling the side-stand, wiggling the key, removing & cleaning and reinstalling fuse 1 and fuse 3 (and all other fuses for good measure), and some light percussive maintenance (lightly smacking the RID). No joy after all of this.

 

I did find this article discussing RID surgery, and I’m willing to try it at some point, but would like to exhaust other potential causes first. https://ibmwr.org/index.php/1997/12/03/rider-info-display-repair-12-hour-clock-conversion/


Are there any other things I should try before opening up the RID?

 

Thanks in advance for any help!

 

Going to try to post a photo:

image.thumb.jpeg.824d9ae95f27c93f2e73fbbc05e27b89.jpeg

 

Ted – Denver, CO

Link to comment
dirtrider
8 hours ago, TedKerr said:

Howdy folks, hoping to get some advise on how to fix a seemingly dead RID on my 2004 R1150RT. With the key on the RID backlight comes on but all of the expected information – engine temp, fuel level and clock – is gone. The clock is supposed to display with key on or off but it’s gone either way. The bike runs fine otherwise. 

 

After some searching for ideas I’ve tried wiggling the RID wiring, jiggling the side-stand, wiggling the key, removing & cleaning and reinstalling fuse 1 and fuse 3 (and all other fuses for good measure), and some light percussive maintenance (lightly smacking the RID). No joy after all of this.

 

I did find this article discussing RID surgery, and I’m willing to try it at some point, but would like to exhaust other potential causes first. https://ibmwr.org/index.php/1997/12/03/rider-info-display-repair-12-hour-clock-conversion/


Are there any other things I should try before opening up the RID?

 

Thanks in advance for any help!

 

Going to try to post a photo:

 

 

Ted – Denver, CO

Morning Ted

 

Firs thing, make sure that the side stand is UP, if it is then make sure the side stand switch is plugged in & working.  

 

Next thing, make sure that fuse #3 is good (not just by looks but either ohm it out or just replace it).

 

If nothing from the above then access the RID pigtail plug, then test for 12v on the red/white wire (all the time).

 

Next,  test for 12v on the green/black wire with the key on. 

 

If you have 12v where it belongs then you can usually find used RID's on E-Bay for around $50.00 to $100.00 (keep looking until you find one at a reasonable price, or contact the seller & offer them less (I have had this work a number of times).

 

Put    (    Driver Information Display BMW R1150   ) into the E-Bay search box. Or try  ( Dash Driver Information Display BMW R1150   ), or try similar phrases. 

Link to comment

Thanks as always DR. I should have mentioned that I checked post continuity on fuse 3 and also tried a new fuse there - and the side stand was up during my testing.

 

I guess I’m hoping for power on red/white and green/black as you describe. Believe I’d rather replace the RID than chase down gremlins on the bike, since used RIDs aren’t too expensive.

 

To confirm, since my bike is an R1150RT I need an R1150 specific RID - one from an R1100 will not work, correct?

 

It’ll be a few days before I can get back at it but I’ll try all of your recommendations and share the results.

 

Thanks again,

 

Ted

Link to comment
dirtrider
9 hours ago, TedKerr said:

Thanks as always DR. I should have mentioned that I checked post continuity on fuse 3 and also tried a new fuse there - and the side stand was up during my testing.

 

I guess I’m hoping for power on red/white and green/black as you describe. Believe I’d rather replace the RID than chase down gremlins on the bike, since used RIDs aren’t too expensive.

 

To confirm, since my bike is an R1150RT I need an R1150 specific RID - one from an R1100 will not work, correct?

 

It’ll be a few days before I can get back at it but I’ll try all of your recommendations and share the results.

 

Thanks again,

 

Ted

Morning Ted

 

I have ever tried to swap an 1100RT into an 1150RT but my parts book shows that they both use the same  P/N   62137679850  "Drivers Information Display". 

Link to comment

Thanks so much DR for your help. Confirmed I had unswitched power on red/white and switched power on green/black so started RID shopping. Luckily found an immaculate one at a great local used parts seller here in Denver, Steel’s Cycle. It’s back together and good as new. Thanks again!

 

Ted

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...