Jump to content

K 1200 LT -03 Speedometer not work !


Vesseli

Recommended Posts

Vesseli

K 1200 LT -03  speedmeter not work, kilometers, and trip working normally, and ABS, cruice control also, but speedmeter needle only move zero when turn power on, after that nothing happend and not show driving speed.What can check and do ??.

Link to comment
dirtrider
On 5/12/2021 at 1:24 AM, Vesseli said:

K 1200 LT -03  speedmeter not work, kilometers, and trip working normally, and ABS, cruice control also, but speedmeter needle only move zero when turn power on, after that nothing happend and not show driving speed.What can check and do ??.

Speedmeter.MOV

Morning  Vesseli

 

Due to the electronics involved it is very difficult to advise you what to check or do as you seem to have operational trip set & odometer.

 

If your cruise control & ABS  are working then your wheel speed signal is getting as far as the cruise control &  ABS control unit so that part seems OK. 

 

If your odometer & trip set are working then the speed signal should be getting as far as the  instrument panel control unit.  From there on it is mainly in the electronics of the  instrument panel control unit (I have no idea on how to test that).

Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...