Jump to content
TSConver

2011 R1200RT ABS Issue

Recommended Posts

TSConver

Have a brake failure message on the screen.  Looks like it is probably the abs module.  What can I expect to pay for the module?  Hard to find prices on the web.  How much to install it if I decide not to do it myself.

Share this post


Link to post
dirtrider
16 minutes ago, TSConver said:

Have a brake failure message on the screen.  Looks like it is probably the abs module.  What can I expect to pay for the module?  Hard to find prices on the web.  How much to install it if I decide not to do it myself.

Afternoon  TSConver

 

What makes you say it is the ABS module? Could be some other issue, might be a stuck ABS module motor brush (repairable by  ModuleMasters).

 

You need to use a GS-911 or dealer computer to get the ABS  failure code or codes THEN go from there.  Motoscan can probably get you some brake failure codes but per my past experience the brake codes from  Motoscan app don't always match the exact brake failure event. 

 

A new ABS module could run you about $1,885.00 plus incidentals. 

 

Are both front brake lever & rear brake pedal fully returning & not trapping pressure after release???

Share this post


Link to post
TSConver
4 hours ago, dirtrider said:

Afternoon  TSConver

 

What makes you say it is the ABS module? Could be some other issue, might be a stuck ABS module motor brush (repairable by  ModuleMasters).

 

You need to use a GS-911 or dealer computer to get the ABS  failure code or codes THEN go from there.  Motoscan can probably get you some brake failure codes but per my past experience the brake codes from  Motoscan app don't always match the exact brake failure event. 

 

A new ABS module could run you about $1,885.00 plus incidentals. 

 

Are both front brake lever & rear brake pedal fully returning & not trapping pressure after release???

 

The levers feel fine to me.

 

Is it safe to ride with that failure?  Are brakes normal just no anti lock or are they reduced in performance?  I have read they loose performance in limp mode.

Share this post


Link to post
dirtrider
40 minutes ago, TSConver said:

 

The levers feel fine to me.

 

Is it safe to ride with that failure?  Are brakes normal just no anti lock or are they reduced in performance?  I have read they loose performance in limp mode.

Afternoon  TSConver

 

If JUST a module failure then you will have normal UNLINKED brakes with no ABS available. 

 

Did you finally get it started?

 

 

 

Share this post


Link to post
TSConver

No the ews is preventing it.  Hoping it is the antenna ring. I got the price down some more. Gonna take it as is and risk it though after I call dealer on Monday and get a price on them doing the abs module if it is bad.  That will be my deciding factor. If it is under 1k I will likely be the new owner.

Share this post


Link to post
dirtrider
1 hour ago, TSConver said:

No the ews is preventing it.  Hoping it is the antenna ring. I got the price down some more. Gonna take it as is and risk it though after I call dealer on Monday and get a price on them doing the abs module if it is bad.  That will be my deciding factor. If it is under 1k I will likely be the new owner.

Evening  TSConver

 

Well, if you haven't ridden it yet then possibly the brake light will go out once the vehicle starts moving.

Share this post


Link to post
TSConver

So the ABS module was a low voltage error and once I cleared it, it did not come back. The only code is 10491 which seems to be the EWS Ring Antenna.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...