Jump to content

Firmware Upgrade?


MattS

Recommended Posts

During a 12K service last Thursday, my 2005 R1200Gs had its firmware upgraded, presumably to address some issue that other people were having with batteries running down, parking lights remaining lit, and parasitic draws being pulled at the accessory port.

 

I'm getting vastly different results now when using the battery charger/tender -- 71 60 7 688 865 -- made specifically for the '05 and newer models.

 

WHEREAS before it would proceed from green-red and a couple of green-yellows to end up and remain at green-green (full charge), now it behaves quite differently.

 

It goes from green-red through the two green-yellows, and at some point either doesn't go to green-green, or remains there for a short while ... and ends up with only the first green (power) lit, without the second green indicating full charge.

 

FURTHER the 4-way flasher idiot light on the left switchgear is now (a) fully illuminated during the charging process and (b) on a 2-second strobe cycle after the charging process.

 

The evidence might suggest that the battery is fully charged, and the strobe suggests that this level is being routinely monitored and will re-engage the services of the battery charger if and when it is needed -- without the requirement of operator intervention.

 

I suggested to the tech (who will be getting more information next week) that the bike might simply be "waiting for the invasion" now with its once every two seconds red flicker ("Psst ... I'm over here!") ... or else the firmware has made obsolete this expensive and task-specific charger. The flashing red does conjure images of an error message, if not a voice mail. I'll be interested in what the final outcome is, provided it's not a dead battery.

Link to comment
Calvin  (no socks)

I routinely upgrade autos with the customers permission. The upgrades address a variety of small items and usually no one even notices the changes...er glitches...On occasion a function has been eliminated to use the memory for another function. We ask the customer prior to upgrade installation.. we can not go backwards... we can't restore lost functions once an upgrade is done...we are usually aware of major changes...but not all changes are known... upgrade for the upgrade... dopeslap.gif

Link to comment
upgrade for the upgrade... dopeslap.gif

Sir, your firmware needs new firmware.

 

What? Huh?

 

Sorry, sir. Here is my receipt, your receipt ... and your receipt for my receipt.

 

Gesundheit!

Link to comment
the_moviegoer

My BMW charger does the same thing! I guess I also got the 'up'grade at some point. I did end up with a dead (sleeping?) battery a couple of weeks ago (hadn't ridden in a while, bike connected to BMW charger); i.e., it was so low on juice that neither the BMW nor my old batter tender seemed to recognize it as a battery. I had to get it started with a regular battery charger, then put it on the trickle charger. I think the smart thing to do, with this 'up'grade, is to disconnect the BMW charger when you have 2 green lights! Now that I'm riding more again, I'm just going to put the BMW charger away.

Link to comment
ShovelStrokeEd

(I think I'm going to get an airhead next)

 

Already have one and the simple life is sure grand.

 

I happen to have a set of K100 forks and brakes lying around and I'm considering making a steering stem to upgrade the forks on my '78 R100S. Sure would make a great around town and day trip kinda bike in that configuration.

Link to comment
During a 12K service last Thursday, my 2005 R1200Gs had its firmware upgraded, presumably to address some issue that other people were having with batteries running down, parking lights remaining lit, and parasitic draws being pulled at the accessory port.

 

I'm getting vastly different results now when using the battery charger/tender -- 71 60 7 688 865 -- made specifically for the '05 and newer models.

 

Matt,

 

My buddy and I bought 05 Rt's the same day. I went in for my 600 about a month ago and got this firmware update... no issues, although I've been riding almost every day so I haven't been on my charger since the upgrade. My buddy however, went in a week after me for his 600 and he IS having issues. He has had a flat battery twice now (post upgrade) where he never had any issues before the upgrade. Also, we've noticed his charger (the new CANBUS one) comes on with green power and solid red, but after less than 10 secs, goes to flashing red which I believe indicates some kind of error. Consequently, we went direct to the battery with the old style battery tender. He plans to take it in Tuesday and have the dealer look at it.

 

We were told by the service manager that the reason for the upgrade was the battery drain which was only supposed to have been an issue when the bike was turned on momentarily and not allowed to "complete the boot process", eg didn't get past the red then yellow triangle lights. The premature shutdown would cause 1-2 curcuits to remain open with a small but steady current draw.

 

I'll try to check back in once we know what happens with my buddie's bike.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...