Jump to content

What is the Most Recent Firmware Version: 05 R1200RT


Recommended Posts

I am in the beginning stages of troubleshooting the ESA on my 05 R1200RT. The pre-load works just fine (One Helmet, One Helmet & Luggage or Two Helmets) (Back of the bike goes up and down when in neutral and the engine is running). The part that's not working (both front and back shocks) is the damping/dampening. I've read in great detail, and it appears a firmware update MAY address the issue. I can't remember when/if the update has ever been conducted. With my GS-911, I can see the version, but I don't know what the most recent version is.


Does anyone out there know the most recent version number for the 05-08 hex's? I'd hate to spend the money if I already have the most recent version.



Edited by jay1622
Link to comment

Evening Jay


You will probably have to contact your BMW dealer to have them input your VIN to get the latest firmware iteration FOR YOUR BIKE.


I have a number of service bulletins on the 05-08 ESA issues & none have anything pertaining to the dampening part (all are for the preload failures or preload fail to calibrate)-- These usually just increase the power sent to the rear strut to overcome a sticking preload drive.


Even then it depends on if your bike still has the original rear strut or the updated strut.


The only thing that I have on the early 08 ESA firmware is (K024-06-08-500) for the potentiometer type of ESA. This is very old data so it might have been updated a few times since.

Link to comment

I understand; that makes sense. I guess the next step is to figure out what to measure, and then measure for voltage to see if there's anything being sent to the little stepper motors for the lower part of the shocks. That'd be my way of knowing if: 1) the "signal" is being sent, and 2) if the stepper motors are bad. I just kinda figured it was a signal issue since they both took a poop at the same time.


Mine are ESA1. Time to do some more digging. Any thoughts?

Edited by jay1622
Link to comment

Morning Jay


With the preload part working that does kind of point to the control switch part working. (you are giving it a quick press (not a long press) to operate the dampening?)


And with both ends quitting at the same time that sort of tells us it is probably not the struts themselves. (possibly both struts but not likely)


So that leaves the ZFE or ?????


Have you ridden the bike then tried to adjust the dampening or are you doing all the testing sitting still during storage?


WHEN did the dampening quit working (any & all info on this can help us help you)


From this far away it sort of points to the ZFE control part (either confusion, or failure, or as you mentioned possibly a firmware issue)


I guess I would try a battery disconnect for a couple of hours then a reconnect, then a new TPS re-learn--maybe see if that allows the ZFE to FULLY re-set itself.


I don't have much on the early ESA dampening control side failing as I haven't ever seen that side of the system fail before (plenty of history on the preload side failing). I have also seen a couple of early ESA control switch failures but the dampening side has been pretty solid.


The front & rear use different (separate) wiring between the strut dampening control & ZFE so a simple wire disconnect doesn't seem likely (unless one end failure (or one end short to ground) effects the system operation???)


Anything done to the bike lately that c-o-u-l-d have effected the ZFE or caused a system confusion?


What is the dash now showing for dampening position?










Link to comment

Morning Jay


I sounds like Karl wants to take over & work with you on this ESA issue so I will step away & let him take the lead.


If you need anything specific that I can possibly help you with you can PM me.

Link to comment

(As I plan on getting into the weeds, I'd like to keep this here in the event it may help someone in the future. Thank you though).


I honestly can't recall when it last worked. I've always kept it on the Comfort setting. I think I discovered it was in-op in the last few weeks. The last time I know it worked was about three years ago (Like I said, I'm a Comfort guy).


Regarding the switch working? Yes, I agree. If the pre-load part works, we know the switch is communicating with the computer. And, yes, regarding the quick press (cycling through the ESA options, i.e. Helmet, Helmet & Luggage, 2 Helmets)? I am using the switch properly, as you described.


I've tried cycling through the damping settings (Thank you Karl) in all sorts of settings, i.e. 1) on, not running (looking to detect audible signs of engagement), 2)running while not moving, 3) running, not moving and 4) (my favorite, while coasting down the decline on my street) on, not running while moving. All of these situations with negative results.


FWIW, I use the BMW CANbus maintainer (the grey box with the lights) and recently change dthe battery with about three hours worth of being disconnected.


Note: 05-06 Hex R1200's appear to have the same colored .35 wire for the RT and ST. Should be the same for the GS.


Looking at the wiring schematic for the motor, it is not a regular electrical motor (rotating); rather, a pulse motor (in/out).


Within the next few days, I'm going to use a multi-meter and see what voltage is being sent between the upper and lower pulse sections of the motor (4 wires total, two for in and two for out). Based on what I find, I'll take it from there I guess. If there is zero signal/voltage? Well, it points more toward the ZFE then, yes?


I did conduct a major maintenance a while back (Clutch, rear main seal, gear box clean-out)... I'd love to discover my dumb self forgot to reconnect something.


Oh... I do see the different settings being shown on my dash, i.e. Comfort, Normal & Sport.


I'll follow up as I dig deeper. What do you think of these points?

Edited by jay1622
Link to comment

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...