Jump to content

Nav 5/iPhone Problem


tlc

Recommended Posts

I have a '14 RT with the audio system, a Schubert C3 Pro with the BMW Communication System, and an iPhone 6+. The setup has worked fine for about the past 18 months. Recently, however, I have not been able to use the phone.

 

When I try to either make or receive a phone call the GPS screen shows the details of the phone call, and the iPhone screen shows details of the phone call, but I cannot hear anything. If I answer a call the caller cannot hear me, and if I call someone they cannot hear me.

 

Can anyone suggest where I should look for problems?

 

Link to comment

Check the settings on the Iphone under audio (?) where you can tell it how to handle phone calls---like "speaker" or "BT headset" or "auto" etc. Try changing the settings.

Link to comment
Check the settings on the Iphone under audio (?) where you can tell it how to handle phone calls---like "speaker" or "BT headset" or "auto" etc. Try changing the settings.

 

I tried that, and it does not make a difference.

Link to comment

I have an iphone 6.

Mine works fine, so I suggest that something has changed, even if you didn't initiate it.

My best suggestion is to wipe the lot and start from scratch.

So

Delete the Nav5 in your phone.

Delete the pairing in your Nav5

Delete the pairing in your bike

 

Follow the instructions in your User manual t the letter.

 

It's the quickest way to get things working again.

 

 

Link to comment
I have an iphone 6.

Mine works fine, so I suggest that something has changed, even if you didn't initiate it.

My best suggestion is to wipe the lot and start from scratch.

So

Delete the Nav5 in your phone.

Delete the pairing in your Nav5

Delete the pairing in your bike

 

Follow the instructions in your User manual t the letter.

 

It's the quickest way to get things working again.

 

 

I did that, or at least I think I did. My iPhone has a long list of Bluetooth devices. After I deleted the connections having to do with the communications system, I noticed that the Nav V was at the same position (#3 of about 12) on the list as before. I would expect it to go to the bottom of the list after deleting it.

Link to comment

Just two quick and probably useless thoughts.

First: which iOS version are you running?

The present one (9.2.1) has given me nothing but troubles since installed, especially when it comes to connecting/synchronizing with other devices.

I've been told 8.3 should be available soon and hopefully address these issues, so it may be worth waiting for it.

Note that I am on a Stone Age 4S.

 

Second: I have a friend with 6S which has had random disconnections when using wireless. He went to the Apple Store and they swapped the phone with no questions asked. Apparently it's a known hardware problem and Apple Stores have been instructed to swap phones with these problems.

May be worth a shot.

Link to comment

Wouldn't rule out an issue with the BMW Communication System, not the most state of the art device anyway and understand there is a new update that needs to be completed by your dealer. The system has the same 3 year warranty as your bike.

Link to comment
Just two quick and probably useless thoughts.

First: which iOS version are you running?

The present one (9.2.1) has given me nothing but troubles since installed, especially when it comes to connecting/synchronizing with other devices.

I've been told 8.3 should be available soon and hopefully address these issues, so it may be worth waiting for it.

Note that I am on a Stone Age 4S.

 

Second: I have a friend with 6S which has had random disconnections when using wireless. He went to the Apple Store and they swapped the phone with no questions asked. Apparently it's a known hardware problem and Apple Stores have been instructed to swap phones with these problems.

May be worth a shot.

 

My iOS version is 9.2.1. I have not experienced any unusual problems with other devices.

Link to comment
Wouldn't rule out an issue with the BMW Communication System, not the most state of the art device anyway and understand there is a new update that needs to be completed by your dealer. The system has the same 3 year warranty as your bike.

 

I thought I recalled hearing that there was a 3-year warranty on the system; that's good to know. I emailed Schuberth tech support. The good news is that I got a response within a half hour. The bad news is that the BMW Communication System is unique to BMW, and I will have to deal with them. That does not give me a warm feeling!

Link to comment
Wouldn't rule out an issue with the BMW Communication System, not the most state of the art device anyway......

How do you know that?

Are you an RF Tech?

Bland statements like this are not helpful and might steer the user in the wrong direction.

I had mine working just fine with with Iphone5 and now Iphone6 using the SRC system.

Connectivity can fail sometimes if the timing/sequence during startup is wrong.

But from everything I read, the BMW Communicator seems to reliable connect every time.

Iphone bluetooth connectivity problems happen in all kinds of vehicles.

I drive 5~6 vehicles between work and personal and "all" of them have failed more then once to connect reliable or showed issues like others couldn't hear me/I couldn't hear them or both (despite being connected).

Bluetooth is not bulletproof.

Link to comment
Wouldn't rule out an issue with the BMW Communication System, not the most state of the art device anyway......

How do you know that?

Are you an RF Tech?

Bland statements like this are not helpful and might steer the user in the wrong direction.

I had mine working just fine with with Iphone5 and now Iphone6 using the SRC system.

Connectivity can fail sometimes if the timing/sequence during startup is wrong.

But from everything I read, the BMW Communicator seems to reliable connect every time.

Iphone bluetooth connectivity problems happen in all kinds of vehicles.

I drive 5~6 vehicles between work and personal and "all" of them have failed more then once to connect reliable or showed issues like others couldn't hear me/I couldn't hear them or both (despite being connected).

Bluetooth is not bulletproof.

 

Was merely offering the OP that it bears investigation. If you think the iPhone or BT version he's operating on is the more likely culprit then you're entitled to that opinion as well. The BMW tech who answered my inquiries suggested I bring my unit down and he would download the update to see if it addressed my issues. Ease up...

Link to comment

I don't have any idea why, but my setup seems to be working fine now. I went to the garage, planning to un-pair, then re-pair everything. Before doing that I turned everything on, and it works! When I first turned it on there was a message on the GPS screen saying no phone was connected. I went to the bluetooth setup page on my iPhone and connected the GPS, and it worked after then. I have tried again several times the past couple days, and it is continuing to work. The sequence I am using is to turn on the ignition (the GPS) and then the helmet. The iPhone is always on, ready to connect.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...