Jump to content

02 sensor has no power - ideas?


dbdicker

Recommended Posts

I tried to install a AF-XIED 02 sensor manipulator into my 04 1150r. got no lights to come on to the device and then tried just to get power from my 02 sensor leads - no dice. I checked the fuse and seems to be fine. has anyone had this problem or suggest the next step for me? i hate to be tracing electrical problems back to the source but not sure what else to do?

 

Maybe a simple part swap will do it - realize there's probably no quick fix here.

Link to comment
dirtrider

Evening dbdicker

 

 

Did you try to see if you have power with the engine running???

 

I presume you have an 1150 with the 2nd load relief relay?

 

Your o2 sensor gets it's (B+) power from the fuel pump relay circuit & the fuel pump relay powers up for only a couple of seconds at key-on, then shuts down until engine cranking or engine running.

 

 

Link to comment

Yes, DR -- I did start the bike and check as well -- nuttin'..........

 

thanks for all input - I actually have a free day tomorrow and was hoping to tear down and fix if it was simple enough........

 

 

Link to comment
dirtrider

Evening dbdicker

 

OK, well it starts & runs so you have power in the main circuit.

 

So your problem must be between the splice where the fuel pump & fuel injectors tie in & the o2 sensor connector (problem usually turns out to be where the green/white wire connects to the terminal in the o2 connector).

 

If not there then you will have to follow the wire back up the harness to see where it is broken (or run a new wire)

 

Do you have the 2nd load relief relay system?

 

 

Link to comment

I will look tomorrow -- I imagine I've been running without the 02 sensor for a very long time now. How I couldn't have noticed it is strange.........

 

I've thought I was missing some "pop" - that's why I bought the AF-XIED module in the first place.

 

Thanks, I'll keep you posted.

 

PS What is a 2nd load relief relay system? I don't know if I have it -- I have a stock 04 R1150R -

Link to comment
dirtrider

Evening Dbdicker

 

There is good chance your o2 sensor was working at riding speeds.

 

The heater basically brings the o2 sensor on-line earlier than the non heated o2's & also keeps the o2 operational at idle when exhaust temps are lower.

 

See picture for relay 2 (2nd load relief relay) location.

 

2004_1150RT%20%20Load%20rel_2_zps2kbuyrmv.jpg

Link to comment
roger 04 rt

When you installed the AF-XIED adapter harness you unplugged the O2 connector and plugged the new harness in between the two old connector halves.

 

It is possible that there is a problem in the new adapter harness. The red wire picks up +12 V on Pin 2 of the O2 sensor. You will have to remove the tank to check this because the O2 sensor connectors are underneath it.

 

Even with the tank off, you should get +12V on pin 2 of the O2 connector for a couple seconds each time you switch the key on. If you have 12v on the female half of the connector on the motorcycle harness your problem is in the AF-XIED harness. If there is no 12v on the bike's O2 connector, follow DR's instructions.

 

If the AF-XIED harness has a defect, Nightrider or beemerboneyard will get one to you quickly, I'm sure.

Link to comment

thanks, Roger and DR -

 

I'm going to start tracing wires tomorrow - thanks -

 

I'm also going to post results only here, I had started this on the ADVrider long sticky thread on the AF-XIED, but this is more appropriate.

 

I'll keep you both posted and appreciate the help much.

 

Dan

Link to comment

BTW, on my stock 02 connector, there are 4 wires entering and only 3 leaving on the male side. Is that normal and correct?

 

And, DR, there is NO RELAY where you have indicated it in your photo - just a hole.

 

 

Link to comment
dirtrider
BTW, on my stock 02 connector, there are 4 wires entering and only 3 leaving on the male side. Is that normal and correct?

 

 

Morning dbdicker

 

What color wires going into connector on engine side? Should have (green/white), (Green/brown), (yellow), (black)

 

O2 sensor side should have (white), (white), (gray), (black)

 

What are you missing?

 

And, DR, there is NO RELAY where you have indicated it in your photo - just a hole--Really doesn't make much difference, the late 1150 dual spark just has two different wire diagrams (depending on 2nd load relief relay present or not) & I just want to make sure we are using the correct one.

Link to comment

Thank you DR, for your expertise and fast replies.

 

I wanted to make extra sure and yes, I made a mistake, was checking the voltage at the wrong spot

 

INDEED - THERE IS 12V appearing on one of the female leads of the 02 connector for perhaps a second after key turn on --

 

I was checking with the bike on, perhaps I wasn't correctly grounded.

 

There are only three leads coming out of the male portion of the AF-XIED connector - colors: Gray, Red, Blue. Is this correct?

 

Is it possible that my AF_XIED device wasn't correctly grounded? I will try that next - connect the ground directly to the battery, instead of a chassis point. If not, I can conclude that the harness on the device is defective and will ask for a replacement.

 

Unless you think I'm not on the right track, i will report later today.

 

Again, many thanks for your fast replies. I'd love to be riding today, it's my birthday and 75 degrees here (finally).

Link to comment
roger 04 rt

Morning DR and dbdicker,

 

I think db is referring to the AF-XIED harness. The female side connector has 4 wires and the male connector only three wires. That is by design. The wire that is eliminated is the O2 sensor Negative wire, which is left floating. The reason is that it is terminated to an offset voltage and resistance inside the Motronic that has to be accounted for. The open pin is Pin 3 on the male half.

RB

Link to comment

Ok - simple - the ground wire needed to go directly to battery.

 

sheesh.

 

I'm a dabbler at this - i change my own oil, I've installed aftermarket shocks, a slip on Akro..... but I'm a dabbler.

 

In my younger days, I built tube audio amplifiers from scratch. No kit, just a schematic and my knowledge. Had a mentor who helped me troubleshoot.

 

he had a saying:

 

98% of the time, it's 100% trivial. A cold solder joint, a loose ground wire.....much more likely than a failed component or something more complex.

 

Thanks all -- I'm going riding :)

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...