Jump to content
Sign in to follow this  
Brian Louw

Cyclops LED headlight - heads up

Recommended Posts

Brian Louw

This is a heads up for anyone trying to install the Cyclops 3000 H7 in a BMW R1200GS(A). This bulb . I posted this on advrider as well, but that forum is overwhelming with the number of posts. The thread on these bulbs is over 2000 posts.

I perused the thread on advider.com and also some Youtube videos and thought I was in good shape.

Started by removing the headlight assembly- really easy, 2 T30 screws, 2 electrical connectors and the parking light just pulls out. I separated the bases from the bulbs and fitted them. It took some patience to get the electrical 'pods 'in between the lights as there is not much room. Installed the bulbs in the bases and connected everything up. Now comes the major problem. I fitted the caps on the back of the headlights and they seemed like a type fit, but I didn't use any force. Reinstalled the headlight unit and connectors and switched them on. Wow! These things are bright, but they shining way too high, so I started turning on the vertical adjuster, but the reflectors weren't moving. WT... ??

I took off the covers and the reflector is kinda floating around. To cut a long story shorter, there are 3 plastic ball and socket mounting points, top middle one is fixed, the one on the right adjusts lateral beam and the one at the bottom adjusts the vertical beam. The vertical and lateral balls had popped out of their sockets and I spent a couple of hours trying to get them back in place to no avail. The unit is obviously sealed and will not disassemble and the clearances are very tight. I suspect this was all caused by not enough clearance between the covers and the back of the fan housing on the bulb.

I contacted Darrell at Cyclops and he assures me they have installed many of these on R1200GS's without any problems as long as you make sure the wire goes down the side of the fan housing, not across the back, but he did admit that the high beam is a tight fit.

Bottom line is I don't have a working headlight now and a new one is $550. :cry:

Darrell offered to send me a bulb with the fan cover removed. The new 3000 model is not easy to remove like in the Youtube video of the 2400 model. There are some screws under a little seal and I didn't want to farkle with that.

Currently I have given it to a competent mechanic/McGyver-type friend who is trying to re-attach the mounts, but I don't have much faith. Like Darrell, he said it should be easy to do, but that was yesterday. ;)

Any experience with this problem or fixes would be greatly appreciated.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...