Jump to content

K1200lt ABS error


Emcee

Recommended Posts

 

I have a fault on my K1200LT 2007 bike. The warning triangle lamp is on and the brake failure lamp flashes once a second when I turn on the ignition. I can also hear a pump whining / running.

 

I have bought a GS-911 to interrogate the bike and the autoscan report tells me that there is the following error on the integral ABS:

 

"17166 Internal control module error - Analogue value, front pressure sensor"

 

Can anyone please offer any advice on what the error means?

 

I can't find any reference on the web to this error code or possible solutions.

 

Any help would be much appreciated.

 

Link to comment

Sadly this sounds very much like a component failure in the iABS unit. Pressure sensors are notorious for going bad and specialized outfits such as Module Masters are having a very tough time sourcing the parts needed for a rebuild.

 

If you are based in Europe you can try contacting Carmo Electronics in The Netherlands: they can fix BMW ABS units (both cars and bikes) and may be able to source the parts.

 

Link to comment

Thanks for your comments.

I will post an update once I have found the actual problem or solution.

I would like to get some detailed information on the iABS but any information is very scarce.

I am a very hands-on person and I would like to try to repair the problem myself but worst case I will take it to a local dealer if all else fails.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...