Jump to content

Rough Idle, Throttle sticky?


dzervit

Recommended Posts

So after ringing out the RT on my first track day this past Monday (was a blast, poor RT took a beating) I've notices a couple new 'features'.

 

1. It doesn't quite idle the same. Seems to chug and shake more than I remember.

 

2. It often doesn't like to return to idle after letting up on the grip. Occasionally I can pull in the clutch and it hangs around 2K for a few, then decides to return to idle.

 

Still runs like a champ, no fuss, no other odd noises. Anything I should look at before taking it to the dealer?

Link to comment

Did you take it to Gratton? or Gingerman? I love Gratton. Reminds me of mountain biking the way it goes over thsoe hills.

 

I'd have the dealer check it out. Maybe pinning the throttle so many times going WOT on the main straight got the servos out of synch. I doubt it's anything serious.

 

The throttle isn't mechanically sticking is it? It could also be a throttle cable that come off it's track or it some how hanging up.

Link to comment

chug and shake

You know, my RT does this periodically. It's done the entire life of the bike. Has over 42k now and like yours runs great and it gets awesome gas mileage. It's never chugged and shaked enough for me to worry about it but sometimes it is annoying. BTW my '05 RT still has the original software load on board. Be interesting to know if RTs with up dated software "chug and shake" at idle. If you figure out what it is please tell.

Link to comment
Did you take it to Gratton? or Gingerman? I love Gratton. Reminds me of mountain biking the way it goes over thsoe hills.

 

I'd have the dealer check it out. Maybe pinning the throttle so many times going WOT on the main straight got the servos out of synch. I doubt it's anything serious.

 

The throttle isn't mechanically sticking is it? It could also be a throttle cable that come off it's track or it some how hanging up.

Grattan. Was a great track, can't wait to do it again. So many turns, and those off camber turns are tricky!

 

Well, I guess I'll head up to the dealer in a few and see what they say. The 'throttle stick' is weird - doesn't feel like a cable, the engine just sticks around 2K when I pull the clutch in. Sometimes it does down to idle after a few seconds, other times says until I engage the clutch a touch and it kicks down. Odd.

Link to comment

Turns out it was a disconnected vaccum hose. Go figure. Purrs again at idle and throttle stick issue has not shown up again. Dealer had some time and hooked it up to the computer tester and gave it a clean bill of health. Woo-hoo! clap.gif

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...