Jump to content

Oil icon is off!


Bheckel169

Recommended Posts

Bheckel169

I recently had my 6,000 mile service and since that time, I've been getting the oil needed icon on my screen. After awhile it goes away, but I don't need oil. I've checked that several times and even added a little more to make sure it was slightly higher then the middle of the sight glass. Anybody have the same problem?

Bruce

Link to comment

If you just had a service done, why isn't the oil up to the top of the sight glass? Mine always is after an oil change, and stays that way for quite a while. I've never had the oil icon appear, but then I always keep my oil near the top of the sight glass. Try it; you might find the icon disappears.

Link to comment
I recently had my 6,000 mile service and since that time, I've been getting the oil needed icon on my screen. After awhile it goes away, but I don't need oil. I've checked that several times and even added a little more to make sure it was slightly higher then the middle of the sight glass. Anybody have the same problem?

Bruce

There was a service bulletin out on my '06. I just had the 18k service, and they performed a fix under warranty. Same issue described, and identical to the issue described in the service bulletin. Inform the dealer and ask to get it fixed.

Link to comment
Bheckel169

Thanks. I knew somebody on this forum would recognize a similar problem. I'll take it in and have them fix the problem. Now I just have to figure out what to do with the other icon that shows up on my screen that eerily looks like a naked woman.

 

 

Only kidding!

Bruce

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...