Jump to content

Lowrance GPS Owners


wbrissette

Recommended Posts

wbrissette

So, I found a great deal on the Lowrance 350C and decided to get it. I used in the car a few times before the mounting hardware for my bike came in. What I have discovered is that this unit probably isn't going to cut it on a bike. At least not mounted using the U-Bolt on the handlebar. Before buying the RCU shelf, I want to know if I'm simply wasting my time.

 

Even with padding at the bottom of the base, the vibration was a bit too much and turned off the unit while riding. Will the RCU shelf help, or am I really asking for too much from a unit that has a hard drive in it?

 

Wayne

Link to comment

The power coming loose and shutting of the system is the same problem I have with my iWay 500c. It hapens in my F350 too. The F350 bounces a bit and the plug disonnects. I have to reconnect it each time. In my truck I use the window mount. I have also tried resting the base of the unit on the dash and then connecting the window mount. The window mount holds it steady and the dash supports it. This would be like the shelf you want. The result, the power still disconnects.

 

On the bikes I have ram mounts setup and the same issue comes up.

 

I am not happy with it these days. When it is on it works great but then it turns off and annoys me again.

Link to comment
wbrissette

In my case, it's not a matter of the power coming loose. I was running the unit off the battery only. However, I think the vibrations from the handlebars are simply too much for the hard drive. I'm not sure that placing that unit on a shelf is going to solve the problem either.

 

Wayne

Link to comment
Jerry Johnston

I have the 500c and while it's a heavy unit and I don't thing a good unit for a motorcycle due to using a fairly good sized hard drive - looks like a standard 2.5" laptop drive. I have a small piece of foam under the unit mounted in the car. I haven't had any problems with it shutting off, is it possible the batteries vibrate enought to shut it down. I'd try packing foam or tape around them just to see if that's it.

Link to comment
wbrissette

Well, I added some thick foam to the RAM mount and that didn't help this morning. So, I went to the local BMW shop and picked up a shelf. I'll see if it makes a difference. If it doesn't, I've made up my mind to ditch the iWay350 and get the Zumo 450.

 

Wayne

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...