Jump to content

Computer read out has changed!


Gkgeiger

Recommended Posts

I just got my R12RT back from the dealer. Had an annnual service and 2 recalls (banjo bolt and re-route of cable). Now my computer read out has changed. I can no longer scroll to the oil check, but it appears every time I stop. What's up? The dealer didn't know and the techs were out to lunch.

Link to comment
I just got my R12RT back from the dealer. Had an annnual service and 2 recalls (banjo bolt and re-route of cable). Now my computer read out has changed. I can no longer scroll to the oil check, but it appears every time I stop. What's up? The dealer didn't know and the techs were out to lunch.

 

I know this is going to sound strange but for me the same behavior spontainiously exhibited itself. 1week after owning the bike suddenly Oil level only appeared when stopped.

Link to comment

It was my understanding that the oil level meter only appears when the bike is at idle. I have an '06 and it doesn't let me scroll to it while the bike is in motion.

Link to comment

I'm not sure there's anything wrong. If you mean that while riding (moving) you can't scroll too the oil check then I'd say that's normal. The oil check's not supposed to sample the oil level until certain criteria are met (engine up to temp and running at idle, side stand retracted, not moving). If all of these are not satisfied you won't be able to get to the oil screen. I think some of the earlier sofware versions were allowing people to get there at inappropriate times and causing confusion about the actual oil level. Just my understanding here but you may not have a problem.

 

By the way, if I leave my BC on the oil check setting, it immediately switches to temperature when I begin moving. Once stopped again, it will switch back to oil check. All other BC functions can be accessed anytime. I believe this is normal.

Link to comment

I can cycle through all the functions on the computer and sometimes I get the oil with a checkmark (while moving) and sometimes the oil reads (------)doesn't matter if moving or stopped. I have my 12,000 service tomorrow where they will update the software to fix the horn problem (Horn will only let me blast it twice then it shuts down till I turn bike off (See Me so horney thread) I'll report back if the software update changes the oil reading availability while moving confused.gif

Link to comment

My '06 RT was built in February '06, and my oil level check function has worked the way you describe since I got it, i.e., you can only scroll to that function when stopped, in neutral etc. When moving you cannot scroll to the oil check function. Did the dealer update your bike's software and not tell you?

Link to comment

At least you guys can see the "oil" readout. I bought a new 2006 R1200RT thumbsup.gif 3 weeks ago and I dont have the oil readout at all confused.gif I just took it into the dealer for the 600 ml service and they had not a clue as to why I\they could not see it? They updated the computer to the lastest update and still no success. Whats up with that eek.gif

Link to comment

My 2006 R12RT will scroll to the Oil display only when I'm stopped. It switches to the air temperature display when I start moving then back to Oil when I stop. While moving, the Oil display does not appear when I scroll.

 

I understand that is the normal and (currently) desired behaviour.

 

For the first/early R12RTs, I believe that the Oil readout was an option so may not appear on some bikes. By the time mine was built it was part of the standard BC display.

Link to comment

All I know is my bike has 26k miles now and all of a sudden it's working differently. They must have done some sort of an computer update. At least I know that some of your bikes worked the way mine did until today..

Link to comment

Mine is an early 2006 - delivered in December, 2005. At motion or at rest, the (somewhat flakey) oil level appeared when scrolling before the temperature until I recently had the upgrade, which consisted of a new sensor (float) and software. Since then, it only appears when stopped and with the oil level at the halfway mark in the sight glass, it takes over a hundred miles of riding before the check mark appears! Prior to the "upgrade", the <!> would appear intermittently when the level was below 3/4 full in the glass.

Link to comment
At least you guys can see the "oil" readout. I bought a new 2006 R1200RT thumbsup.gif 3 weeks ago and I dont have the oil readout at all confused.gif I just took it into the dealer for the 600 ml service and they had not a clue as to why I\they could not see it? They updated the computer to the lastest update and still no success. Whats up with that eek.gif
As useless and annoying as the whole thing is, I'd say you have a feature, not a problem!
Link to comment

My '05 RT seems to be okay. I can scroll thru all readouts whether moving or at idle. Sometimes, the oil display shows a check mark, sometimes it shows "-----" and every once in awhile shows "<!>" when it THINKS the oil level is low.

Link to comment

One thing I can say for sure about the way it used to work, is that if I kept the oil level above the half way point, I always got a check mark. I could check it anytime just by scrolling through the screen. It always appeared after the avg mpg and just before the temp.

Link to comment
At least you guys can see the "oil" readout. I bought a new 2006 R1200RT thumbsup.gif 3 weeks ago and I dont have the oil readout at all confused.gif I just took it into the dealer for the 600 ml service and they had not a clue as to why I\they could not see it? They updated the computer to the lastest update and still no success. Whats up with that eek.gif

Mine was doing the same thing but I didn't even know I had an oil function. I took mine in because it would hesitate and stumble when you twisted the throttle WFO. They had it for a couple days before they figured out the bike had been loaded with the wrong software at the factory. It had been loaded with a "slower" program for another country. It wasn't loaded with the North American program. They clued in when they couldn't apply the software updates that they should have been able to. As soon as they loaded the proper program and did the updates, the stumble disappeared and I now had an oil function to check! thumbsup.gif Mine works like everyone else has described, at idle, warmed up, kickstand up. Never see the "!", just always get the check mark. clap.gif

Link to comment

They put new software on your bike so that it works like the 06 bikes. Mine was like yours but when I got the new float that helps solve the oil check from coming on too soon my screen changed the same as yours. Your bike is no "up to date". My oil check function works much better now so its an improvement in my view.

 

 

I just got my R12RT back from the dealer. Had an annnual service and 2 recalls (banjo bolt and re-route of cable). Now my computer read out has changed. I can no longer scroll to the oil check, but it appears every time I stop. What's up? The dealer didn't know and the techs were out to lunch.
Link to comment
I can cycle through all the functions on the computer and sometimes I get the oil with a checkmark (while moving) and sometimes the oil reads (------)doesn't matter if moving or stopped. I have my 12,000 service tomorrow where they will update the software to fix the horn problem (Horn will only let me blast it twice then it shuts down till I turn bike off (See Me so horney thread) I'll report back if the software update changes the oil reading availability while moving confused.gif

 

Just got my bike back from 12,000 mile service and they did software update 7.0 and now the oil check can't be found while on the move. The windshield button also wouldn't move the windshield (after support arm replaced) so they had to reinitialize the windshield button and it began working again. Horn also works every time I press button now. I'm waiting for software update 125.6 lmao.gif

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...