Jump to content

05'ST High beam light is out


kopov260

Recommended Posts

Today my high beam light went out on my ST. When I switch to high beam both bulbs are going out and when I return the switch back to normal position low beam lights are on in both lamps. Question: when you turn on the high beam, is the low bulb suppose to go out or it should stay on. I just didn't pay any attention before and it seems not right.

Anyway if any of you ST owners had this happen please let me know. Meanwhile I'll get the bulb tomorrow and try to replace it. It is such a hassle to go to the dealer again.

 

Thanks.

Link to comment

Lamp changes are relatively simple on the ST, both of my low beams have went and you should be able to change it no problems.

 

Both at separate times but within a month of each other. Considering the much lower usage of the high beam, are you sure it's the lamps that are away? I'd test the first one you take out with test lamps/continuity checker to prove it's the filament. Quite an unusual coincidence if it is both gone at the same time. If it's not the lamps then a trip to the dealer may be on the cards.

Link to comment

Well the warning simbol points to the headlight bulb. I do use my high beam a lot. Here it's necessary since you deal with so much traffic and it makes you more visible.

Thanks anyway.

Link to comment
Well the warning simbol points to the headlight bulb. I do use my high beam a lot. Here it's necessary since you deal with so much traffic and it makes you more visible.

Thanks anyway.

 

Update-I did change the bulb and everything is back to normal. When the high beam is on the low beam goes out. I won't use the high beam for as much as used to anymore.

thumbsup.gif

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...