Jump to content

R12RT Cruise Control


nail24

Recommended Posts

I washed my R12RT tonight and after drying it off I went on a run to blow off the residual H2O. When I engaged the Cruise Control I got the SET light but the cruise control dropped off within 5 seconds. after several attempts it stayed engaged for about 45 sec. then dropped off again. By the time I reached home (15 miles) it wouldn't engage at all. Before you ask, I washed it with a shower nozzle none of that high pressure stuff. Any ideas. My closest dealer is 100 miles away and even though it's under warranty I don't need an out and back before i head to the beemer rally in Boone, NC this weekend.

Link to comment

Do you have a 2005 with the 4 way flasher switch? I have read somewhere on this site that the rubber seal around that switch goes bad and lets water in.

Link to comment

OK, it worked after sitting in thegarage over night. I'm going to saturate the flasher switch with h2o and see if i can duplicat last night's problem

Link to comment

Hey,

 

I've got a watter problem with the left turn signal. Riding back from VT (lots of rain) the signal would start on it's own. Many times I could not cancel it without first engaging it with the left switch. Once I did that, it would cancel but would start right back up again. Once it dried, all was well again. Maybe this is related to the same water leak problem???

 

I'm having it replaced at the next 12K service (the only service I have the shop do)...

Link to comment
Paul Mihalka

With these switch problems I would not saturate them with water but saturate them with WD40. I know they should be waterproof, but this might help, at least for a while.

Link to comment

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...